JackTrip version 1.7 is the last one that works on my setups

I have used JackTrip in the past, but after updating JackTrip it stopped working. The last three updates have all done the same thing, the app just closes itself.

I have a Win 10 Asus Zenbook, with Steinberg UR22 audio interface. I have AT&T fiber internet and use wired Ethernet. All of this used to work with JackTrip. I made some JackTrip radio recordings as Triangle Park studio. Then after the update several months ago it stopped working. The computer still works, the audio interface still works, Cubase still works, etc. Nothing has changed, no Windows updates, no audio interface driver updates, just JackTrip updates.

You can see what happens now in this video: JackTrip doesn’t work on my Zenbook anymore
It’s been like this for months even though I contacted tech support and tried lots of things they recommended. Once the app opens, it makes connection to the ‘Virtual Studio’ and then there is this horrible whining noise, then the app just closes by itself. The last three versions of JackTrip all do the same.

In an effort to eliminate what might be causing this problem I tried using JackTrip on a different computer. This is also Win 10 but with an i7 and Lightning bolt ports connected to a Universal Audio audio interface. Same AT&T fiber but a different Lightning bolt Ethernet dongle. It does the same thing. The app will open and start to do it’s thing and then it just closes itself. You can see what happens in this video : JackTrip doesn’t work on my new Zenbook either

To check new video functions, I tried to open the app from the Firefox browser instead. It does the same thing. You can see this here :JackTrip doesn’t work from the browser either

Has anyone been using JackTrip in the past but found that the latest versions don’t work anymore?

1 Like

Sorry to hear about the trouble. I watched all three videos and saw that there are a lot of extra screens glitching, which indicates some system confusion. This can happen when the browser history has several previous login attempts.

Three quick things to do:

  1. Start by completely logging out of JackTrip.
  2. Use Chrome, make sure it is up-to-date, and completely clear the browser history.
  3. Unplug the interface, wait a minute, plug it back in

See if that helps. If not, additional suggestions follow:

  1. Log completely out of JackTrip.
  2. The Virtual Studio was designed with Chrome, so use it!
  3. Open Chrome and completely clear the browser history. Go to the advanced tab of the “Clear Browser History”.
  4. Unplug the interface
  5. Reboot the machine
  6. Update Operating System
  7. Update Chrome
  8. Update all audio drivers (plug in interfaces to update them)

One more thing: in all three videos, the headphones are in the same place on the keyboard! I would make sure that nothing is on the keyboard, possibly pressing a key!

These tips have worked for many of the people I support. See if they help you.

Another thing to check, and apologies if you have already done this:

In the Virtual Studio settings, make sure that the interface you want to use is selected. , i.e. the Steinberg UR22 driver. The settings button is on the bottom right corner.

That said, there is an ASIO driver from Steinberg that is not working with JackTrip, so perhaps that is the problem.

Also, the latest versions of JackTrip have feedback detection, and considering the feedback you are getting, that could be why the program closes automatically.

@miked, any suggestions?

We have found that there are several ASIO drivers on Windows that cause JackTrip to crash when it tries to initialize them. This happens immediately at startup because asking you which interface to use is one of the first things that JackTrip does.

This does not seem to be a problem specific to JackTrip. Searching online, we have found numerous complaints of people experiencing the same crashes when using these drivers with other software. In particular, we’ve verified these drivers are the source of crashes:

  • Realtek ASIO (sadly, this is often pre-installed on Dell laptops)
  • Generic Low Latency ASIO Driver (from Steinberg)

You can see if you have one of these installed by running “jacktrip.exe --listdevices” from the command line.

This list isn’t complete. It’s just what we’ve found and been able to confirm from testing so far. In the past, several prominent vendors have also been known to publish ASIO driver updates that cause crashes. Upgrading to the latest driver release fixes the problem. Unfortunately, this just seems to be the current state of things for low-latency audio on Windows.

The only known way to fix it this problem by removing the offending drivers.

In 1.10.0 we added “Realtek ASIO” to an internal blacklist so that JackTrip just ignores and doesn’t try to use it. The “Generic Low Latency ASIO Driver” will similarly be blacklisted in the next release.

1 Like

@ParkJames all three of your videos show Steinberg’s “Generic Low Latency ASIO Driver” being used. This can also be seen from the popup window that the driver opens briefly before crashing. I’m 99.999% certain that is the source of your problems.

I see that in March 2023, there was a Yamaha Steinberg USB driver update.
Yamaha Steinberg USB Driver Updates and Downloads | Steinberg.

Is that the same one that crashes? If not, great, we have a potential fix.

But if the link above is the same one that crashes, what options do
people experiencing this problem have? I suppose they could continue
using 3 versions back until there is an ASIO driver for their device
that works.

The horrible whine is not feedback I assure you.
There is no way to change the settings as the app closes without responding to any clicks.
An ASIO driver from Steinberg that is not working? When did that happen? I always used
the Steinberg for the JackTrip radio recordings I made as Triangle Park.

No, I am not using those drivers.

No, I am not using the Generic driver from Steinberg.

I did not update the driver.

Please see the screenshot from your video below that clearly labels the
driver you are using is “Generic Low Latency ASIO”

Please see if updating the driver from the link I sent you will make a
difference. You can always uninstall it.

We are doing our best to help you figure out the best solution.

JackTrip seems to run a treasure hunt looking at all the audio drivers,
whether or not they have ever been used. I uninstalled that one since
I have never used it and it made no difference.

I uninstalled the Steinberg Generic ASIO driver which I have never used, no change as you can see in this video.JackTrip horrible noise generator

From the video evidence you provided there is still a connection to a blacklisted Generic Low Latency ASIO driver that is creating a problem.

Please use an ASIO driver that is supported.

The first thing to do is to use the sliders to turn down the input and
output volume.

Then, click on where it says, “Change Device Settings”

See what choices you have there.

Most of the time the app will close before it responds to my clicking on anything but one time I got into the settings briefly. They have not changed since I first used JackTrip - it is still the Yamaha Steinberg ASIO driver that I have always used, including when I made the JackTrip radio recordings. As I said I uninstalled the Generic ASIO driver, which I have never used. There is no change. Once I run the app and “join” the “virtual studio” the app will go through the motions and then it will close by itself, usually before I am able to click on anything. I am running the “Web” version and it works but it is useless because the latency is horrible.

You know there is the “JackTrip app” which is not the size of a full-screen, and then there is the Web interface which shows the video in the newer versions. When I am working in the Web interface, where I can select “Use the desktop app” or the other one “web thing” (which has horrible latency). If I choose to not use the desktop app, thus it is working (but one can not play music that way) and then when I select “Leave” a strange thing happens. The desktop app will open! It goes through the motions, there is that horrible whine sound (even if all the volume sliders are all the way down), and then the desktop app closes itself.

With great respect, the Yamaha Steinberg ASIO driver is the generic one and it says “generic asio” in the screenshot you provided.

It is possible that the reason it no longer works for you is because of changes in the code for current Jacktrip versions and other options need to be considered.

Perhaps a previous version of Jacktrip? Or iw about ASIO4ALL? I can help you with either if those.

Thanks for following up!


Have you updated the Realtek/Windows audio drivers lately? If not Try that.

Do you already have ASIO4ALL installed?

You can book time with me on SynthiaPayne.com

Each version has its own settings. Maybe when you “Leave” and the desktop app opens, the settings are bringing in the bad driver.

I suggest you try using the built in audio system without any externals plugged in and see what happens. Make sure the mic or input volume is all the way down.

I’m like a dog with a bone. arf!