JackTrip App 1.6.0 (with Virtual Studio)

We’ve just released a HUGE new update for JackTrip Core for Windows, Mac, and Linux.

With JackTrip 1.6.0 you can now sign in to your Virtual Studio account and join a Studio with a single click!

Download here:
Windows
Mac
Linux

This means you can join a Studio from your computer without messing with IP addresses. If you’re just joining a Studio, you never have to leave the app!

Here’s a quick how-to we wrote on getting connected with the JackTrip App.

JackTrip can be used with any audio device that your computer supports. That means you can use anything from your favorite headset to the audio interface you work with every day.

If you need the flexibility of classic JackTrip experience, it’s still there. Either choose that option at launch or go into settings and click “Switch to Classic Mode”.

We think this will make connecting to Studios much easier, and we hope you love it. There is plenty more we’re working on to make the experience even better, and we hope you’ll let us know how it works for you!

A huge thanks to everyone who provided feedback and who contributes to JackTrip’s development. We’re so excited this is out in the world for you to use!

6 Likes

Great app. Really works

4 Likes

Just downloaded the app, and it gets stuck on the “logging in” screen. I logged into the account using my Google authentication. I’m on Ubuntu Linux 20.04, logged into the studio through Chrome…

1 Like

Hi Aaron!
We believe we may have fixed the issue with version 1.6.1, would you mind trying it out and letting us know if it worked?
Thanks!
https://github.com/jacktrip/jacktrip/releases/download/v1.6.1/JackTrip-v1.6.1-Linux-x64-binary.zip

1 Like

Russell,

Thanks for the fix! It appears to have worked! I do have a couple other issues/questions… The app seems to get stuck when I try to use the “refresh list” button on the studios (this happens to my brother also, who is using the app on windows). Also, it doesn’t seem to show studios that are shared with me. For example, my brother and I have each created a studio: The one I created show on the website as “my studios” and his shows under “my subscriptions.” On my app, I see the one in “my studio” but not the one he created that I’m subscribed to. He sees the similar (reversed) issue. So I can’t simply connect to his from the app, and he can’t simply connect to mine from the app. Is this normal behavior?

If it makes sense to file these as issues somewhere else, I’m happy to do so. Thanks for all your work, I really love the capability!

Best,
Aaron Dutle

2 Likes

Hi Aaron!
Thank you for being so in-depth with your information!
If possible, it’d be great to have you submit a support ticket at https://help.jacktrip.org/hc/en-us
From there we can work with you on a closer and easier basis.
Thank you!
Russ

1 Like