Old JACK Crashes JackTrip on Windows

It seems that the makers of the Jack Audio Connection Kit (“JACK”) published a Windows release in 2018 that crashes all audio software apps that support it. Unfortunately, the bug is within JACK’s core libraries and deep enough that just checking for whether or not JACK is installed is enough to trigger a crash – even if you aren’t using it at all.

While most people would never be affected by this, I’ve seen it enough times that it seems worth writing about. Here is the bug report in GitHub. Although the root cause was fixed in more recent versions of JACK, it continues to plague anyone who installed a faulty release.

To fix, open the “Add or Remove” software app on Windows and type “jack” into the search bar. Remove any installations of JACK on your computer.

Sometimes Jack is not listed as being installed, but the faulty libraries are still present on your computer. To make sure your system is clean, search for and delete any file on your computer named “libjack64.dll”. Normally, this will be located in “C:\Windows”.

3 Likes

@rebholland This might help you on your recent trouble ticket if JACK was installed some years back.

Well it did something but I’m not sure what exactly.

I tried searching for the .dll as suggested but got a forever ‘working on it’ during the search so tried a command line search instead. Eventually a blue screen error occurred and Microsoft kindly restarted my machine for me.

Once the machine had restarted I proved that JackTrip 1.9.0 was still working reliably, then worked my way up through the more recent versions and 2.1.0 is now apparently working - I’ll try it with audio a little later today if I get a chance.

I did notice that the earlier versions just created a JackTip executable in the ProgramFiles/JackTrip directory whereas the later versions (2.0.2 onwards?) also installed a lot of Qt6 stuff. I guess that’s correct?

Although the latest version is now apparently working it would be nice to know why.

Thanks for your help on this & best wishes to you all.

Hi Reb, did you find and remove the file “libjack64.dll”? That is all you need to do to fix the problem. Windows search getting stuck and crashing your computer sounds like a different problem altogether.

Yes, JackTrip uses a library called Qt. Previous releases used a technique called “static linking” that combined everything into the executable, and we switched to “dynamic linking” in 2.0 which uses separate files.

@rebholland some folks do not know that JACK and JACK2 are completely different programs from JackTrip. Early on JackTrip needed JACK to run but a lot has changed.

You seem like an advanced user who might have experience with the Windows Registry and if so search there for the file that Mike suggested: ‘libjack64.dll’

@miked looks like he says that he called “libjack64.dll” in the command
line - maybe that caused the crash, due to its causing JT to crash?

Thanks Mike & Synthia

Hardly an advanced user as my knowledge of Windows is now about twenty years out of date. Although I’ve had to maintain access to some specialised Windows software for my embedded system development work (ARM and Atmel) I’ve long preferred to do this with Linux virtual machines on my Macs.

I couldn’t find libjack64.dll in a registry search, but it does pull up a few other references which might be related…

jackrouter.dll
jackd.exe
qjackctl.exe
qjackrip.exe
jackTrip.exe
rncbc.org\QjackCtl

Some refer to the Program Files (x86) directory.

The machine ‘blue screened’ again this morning during a file search so I need to chase that down. Guess I might need to relearn a few things about Windows.

Have you run Windows update lately? Not updating the Windows operating system would likely cause problems like crashing.

As for the files you listed:

jackrouter, jackd, qjackctl are all JACK files, and are not necessary to run the current version of JackTrip. The last version to require JACK to run was 1.3, I think.

qjacktrip (it is misspelled in your list - without the “t”) was an early version of the GUI for Jacktrip (whereas previously launching JT was by command line only).

I doubt that you need any of the files listed above, unless you are using JACK or that early version of the JackTrip GUI.

jackTrip.exe is most likely the current version so keep that one.

Hi Synthia,

Yes - Windows thinks it is up to date (the last update completed a few days ago). I tracked down the subsequent blue screens to (1) backup utility and (2) network loopback interface. I ran Dell’s diagnostics earlier today, updating the Bios and a few other things so we’ll see how it goes. Qjacktrip fell victim to autocorrect on my phone as I composed the message. Seems unlikely to be JackTrip related.

1 Like