Audio Interface not responding to advanced audio settings under Windows

I have 2 audio interfaces that I tested under Windows 10 that I do not run simultaneously and both show a behavior of limited responsiveness to advanced audio settings in JackTrip.
Regardless of the settings in the audio interface’s control panel before joining a JackTrip session, the settings always change to fixed settings independently of those in the advanced audio settings of Jacktrip.
for my Behringer FLOW8 I always get

and for my Komplete Audio6 MK2 I get


A preferred ASIO buffer size of 256 samples is far more than I need, as my setup works perfectly well with other online jamming platforms with 8 or 64 samples. For more distant servers I am very keen on reducing my latency.

Does anybody experience similar problems or has managed to fix them?

I’ve worked with a LOT of different audio interfaces on Windows over the past few years, and learned that they all behave differently. Most (including Focusrite, Universal Audio, Presonus) are good sports and allow software apps like JackTrip to set the buffer size without any problems. Others don’t let other apps change their buffer size at all, rudely rejecting any ASIO requests to do so.

Earlier (pre-2.0) releases of JackTrip didn’t account for this and would try using a different buffer size than the interface was actually running at. This obviously led to very poor results. Somewhere around 2.0 we changed this to recognize interfaces refusing buffer size changes, and fall back to what they wanted. In JackTrip, this has the effect of a buffer size immediately flipping back when you try to change it. It’s the audio interface that is doing this.

Many provide a custom software application with their driver that allows you to change the buffer size. I haven’t yet run into any that provide no way to change it, but I wouldn’t be surprised. Every one of these is its own custom snowflake with different quirks.

I recommend reaching out to the manufacturer of these interfaces to see if they have any updated drivers, or additional apps that you can use to modify the buffer size.

Thank you Mike, for looking into this.

Actually both audio interfaces do react to applications asking them to change their buffer size settings. They do so perfectly for JamKazam as well as Jamulus. Only JackTrip displays this behaviour. That makes me think that there is something wrong with JackTrip.

Best regards,


I just ordered myself a FLOW8 to take a closer look. It’s most likely that those applications are not using ASIO drivers, or they think they are changing it but not actually doing so.

1 Like

Both, Behringer Flow8 and Komplete Audio6 MK2 do have ASIO drivers and this is what I use. You may have noticed that in my post there were screenshots of the ASIO control panels of the two audio interfaces. And they do respond normally to Jamulus and to JamKazam.

I like your idea that they may think only but behave differently.

Do you think that order of operations, like when one joins a studio in relation to when the interface becomes active, has anything to do with JackTrip’s ability to communicate with external drivers?

How about Windows/RealTek “Exclusive Mode” in the Advanced Sound Control panel, could it be getting in the way?

Or is this a red herring? Feels like there is more to this than meets the eye.

Hi Synthia,

Until now, what I was referring to, were the advanced audio settings on the webpage which produce no effect. However, the advanced audio settings from within the desktop app do work as expected. Sorry, I discovered this only now but I was under the impression that the web page had, so to speak, higher authority because it is there that a studio session is ended (not just left).

Perhaps this could be clarified somewhere that for advanced audio settings to work properly one has to go to the desktop rather the web page.




I just found out that when changing the advanced audio settings from within the desktop app my audio interfaces respond as expected. It is only via the web page that it does not work.