Basic to more advanced

Genre/use case:
I am a jazz musician (right, I work at the transit district so I can pay rent) who would like to play with other jazz musicians who also went to Berklee

Required gear:
For my basic setup (just to get things going) I use a $700 Win 10 Asus i5 Zenbook with a $80 Steinberg UR22, a $10 USB3 Ethernet dongle I got on eBay, a $100 Senheiser e835 microphone, and $80 Sony MDR 7506 headphones. I have AT&T fiber internet at my home. For my friend I bought a $100 JackTrip Digital Bridge on eBay, another $80 Steinberg UR22, and another $80 Sony MDR 7506 headphones. He has a Senheiser MD421 microphone because he plays saxophone. I just want to say that these choices are not random - I have been a studio consultant most of my life and I used to work at Sweetwater so these choices are the result of decades of experience working in hundreds of places with hundreds of music professionals. The results I am getting sound excellent.

I wanted to take the next step by replacing the Steinberg with my Yamaha MODX7, but it has a native sample rate of 44.1 kHz and JackTrip is only 48 kHz.

So my next adventure will be to replace the Steinberg with my Tascam Model 12 digital mixer, which has the 48 kHz sample rate. Then I can plug everything into the mixer and use it’s USB interface - it will be interesting to see how to route the mixer outputs into JackTrip as I expect at first it will try to route the first two inputs of the mixer instead. The Tascam incorporates a multi-channel recorder, so I should be able to capture jam sessions into separate tracks and remix it later on.

1 Like

Welcome @ParkJames and Thanks very much for taking time to post here! I am delighted to hear that your sound is excellent. Two thoughts: 1) in your first sentence, did you mean to say that you want to play with musicians who also are Berklee alum, or just that you are also a Berklee alum. I think it’s the latter, but who am I to judge?

And my second question: Lots of people run JackTrip successfully at 44.1. Do you want to give it a shot with your Yamaha MODX7?

Please keep us posted on your progress.


Hmm, I was trying it before and got error messages with the MODX. Perhaps there was an update or something changed. I tried it again and it seems like it might be possible. When I run the Yamaha/Steinberg ASIO control panel I can change it to 44.1 kHz, but after I run JackTrip it changes back to 48 kHz. This is when I have the UR22 in use. If I use the Y/S control panel and change it to 44.1 kHz twice, then it will stay on 44.1 kHz. When I run JackTrip (after changing it twice) I can see the ‘meters’ showing audio from the UR22 so that is somewhat promising.

When I tried this with my MODX, again it is fixed at 44.1 kHz, JackTrip doesn’t give me the error message now but I don’t have a long enough Ethernet cable to run into the room with the MODX in it, so my “virtual studio” was not running. (ordered long cable on eBay) It did route the ‘first’ two channels of the MODX USB as I suspected, but the “Main Out” is what I want and that is like ‘USB channels’ 11 and 12 or something like that.

I have Audient Via so I suspect I could use that to reroute the channels.

Also when I run JackTrip app on my laptop, and go into the settings, the sample rate is always 48 kHz and the text is grey, as in can’t change it, even on those times when it looks to me like the audio is running at 44.1 kHz and I can see indications on the JackTrip ‘meters’. Must be a bug, huh?

Nope, not a bug. It is mainly due to Windows wanting to control everything and making it very difficult for your ASIO devices to function properly with JackTrip. Following are my suggestions for clearing the way for your devices to run more smoothly with JackTrip:

In the Windows Control Panel, Manage Audio Devices, on the “Playback” and “Recording” tabs for each device to be used, go to Properties, Advanced, and:

  1. set the default bit depth and sample rate
  2. disable “Exclusive Mode”

This will help to reduce Windows interference with ASIO device functionality. And check up on this change periodically because Windows updates, and RealTek updates will automatically re-enable Exclusive Mode. These settings are buried deep in the:

a. Windows Control Panel, Sound, Manage Audio Devices.
b. there should be an entry for each active audio device - each device has its own settings c. on tabs labled “Playback” and “Recording”
d. select Playback, then the device, then Properties, then Advanced
e. select the Default Format - Bit Depth and Sample Rate
f. UNCHECK ‘EXCLUSIVE MODE’ options (disabling the acceleration and enhancements options also will reduce Windows interference with ASIO functionality.)
h. select Recording tab and repeat #d-g

Repeat this process for each device to be used on Recording (input settings) tab and the Playback (output settings) tab.

1 Like

Nope, not a bug. What you probably see is the interface for running the Bridge hardware, and the Sample Rate for the Bridges will be greyed out.

The interface for running the JackTrip desktop software app is different from the interface for running the Bridge hardware.

When you’re in the software app on the Virtual Studio interface, In the lower right corner, tap “Settings”, then on the left:
a. Advanced
b. Select “Classic Mode”
c. Tab “Audio Backend”
d. Change sampling rate
f. Tap “Basic options” tab
g. Select “Virtual Studio” mode to go back to the Virtual Studio webservice.

It is a bit confusing right now because JackTrip is an open source software application that maintains its own presence, while at the same time, being accessible from inside the Virtual Studio website.

I do think it might be a bug- I have seen times where Jacktrip will get sample rate mismatch issues if another software is open (like a DAW) which sets the device sample rate back to 44.1 while using JackTrip. You get the weird high-voice effect in the audio because of the samples being played faster.

Going to classic mode is one way to solve this but it seems like it would be much better to either allow selecting sample rate in VS settings, or do an automatic sample rate conversion if there is a mismatch.

As for audio routing, JackTrip will try to use channels 1 and 2 only, but you can definitely use some routing software like the one you mentioned to get all channels from your mixer into 2 inputs. That might introduce a bit of latency but not too much

1 Like

Thanks for your input, Andrew. The current interface that comes up when using the desktop app does not have the option to change the sample rate. That’s why I suggested going to Classic Mode to change it. The VS settings interface that shows the sample rate greyed out, is the web interface for the Bridge devices.

On OSX, I haven’t seen a problem with JackTrip getting the correct sample rate. It seems to be a Windows thing and the workaround is disabling “Exclusive Mode”. This allows more than one app to have full access to all of the active audio devices, rather than only those that claim exclusive or priority access. I wonder if those priority or exclusive “claims” could be part of the prospective app’s code.

You can run JackTrip at 44.1 kHz, but Jamulus can only work at 48 kHz. By default, our studios are created with support for both and hence the “Sample Rate” is fixed at 48 kHz. If you change the “Type” to just “JackTrip” you can then select different sample rates (up to 96 kHz).

The JackTrip software app will always set your audio interface to the same sample rate as the studio you are connecting to, because it currently does not have any sample rate conversion capabilities (yet). This means that your audio interface needs to support the sample rate used by the studio, for both input and output, in order for it to work.

The other complexity comes in to play when you have multiple audio applications (DAWs like Reaper, etc) trying to use the same audio interface. JackTrip will always set the audio interface sample rate when you connect, but this doesn’t prevent other apps from changing it themselves and thus breaking JackTrip. We’ve found a fair number of apps out there that do this, and that even seem to have loops to regularly reset the sample rate to whatever they think it should be. This will naturally cause conflicts, and the only way to avoid it is to either not run other apps, enable “exclusive mode” (on Windows), or ensure that all apps are configured to use the same sample rate. This isn’t a JackTrip problem so much as one that applies to all computer audio software.


Thanks Mike! That’s a great tip about setting the Type to only JackTrip rather than JackTrip/Jamulus in order to change the sample rate for the Bridge, per the screenshot. However, it does not change the settings for the desktop software version, right?

Regarding the options for avoiding sample rate conflicts on Windows, did you mean to suggest enabling “exclusive mode”? I usually disable it.

OK, there’s some tips to work on.

I never run more than one audio app at a time. The Yamaha/Steinberg USB driver has a ‘daemon’ that runs without a ‘front panel’, so I was running the app which allows control of that daemon to check on it, and then closing that app, before running the JackTrip app.

It was mightily confusing that when you run the JackTrip app, and click on something within that app, it was opening a browser window. This was never explained in the manual (as in, where exactly is the manual anyway?). I have: the laptop with all it’s cables, the UR22 with all it’s cables, the headphones, the microphone, wearing my Fender bass, leaning on a kitchen stool, looking at my music stand with sheet music on it, and the tablet running Duo so I can see Richard. So I think you can see how I missed what was happening when the browser opened.

My friend is using a bridge, but I am not. So if I have success with using the Yamaha MODX we would have to run the “Virtual Studio” (which I am assuming is a daemon on a Linux server somewhere) at 44.1 kHz. Will the bridge be able to run at 44.1 kHz?

1 Like

Yes, I just started a Studio and changed the sample rate to 44.1 khz. Then I joined with my Bridge and it automagically was set to 44.1 !! Yay. So there you have it. Tried and true.

And please keep in mind that this JackTrip web community is mostly volunteer-driven and just a little over 2 years old. People like you are definitely an asset to our efforts, so please feel free to volunteer your knowledge and expertise.

Thank you!!

1 Like

The way to change the sample rate on the Studio is to:

  1. Start it up!
  2. Studio settings - Bottom left side of make sure the “Type” is set to JackTrip only
  • not JackTrip/Jamulus
  1. Studio settings - Bottom right side and change the Sample Rate to 44.1 kHz

That should do it! Your MODX should be able to connect at 44.1 kHz, and your friend’s Bridge should automatically set to 44.1 kHz.

Please give it a try and let us know! I won’t sleep until I know you’re jamming!

1 Like

It didn’t work. No matter how I try it, I always get the error message. I changed it to only JackTrip without Jamulus, same thing.

I believe that error is because the desktop software client interface is still set to 48k.

Your Yamaha is part of the client connection protocol. In order to change the sample rate for the desktop client, you will need to go into Classic Mode and change the sample rate there. Then return to Virtual Studio mode.

I would be glad to do a Zoom and help get this resolved.