Experience using RodeNT-USB mini and/or Behringer UMC204HD?

Trying to use this while connecting through jacktrip desktop software on imac. Anyone have issues, problems, solutions?? Thank you/

I’ll get together with Pat this afternoon and see if we can figure it out. If anyone else has experience with the gear Pat mentions, please chime in. We’ll report back this afternoon.

I use a Behringer UMC404HD, but my system uses an analog mic (AT2010) → Mix12MX → Jacktrip Analog Bridge. Haven’t tried it with computer connection yet.


Thanks all, for your help. I think I am up and running again.

You are very welcome, Pat. We both learned a lot through this troubleshooting session, eh? USB mics can be tricky. Thankfully you are using a Mac. On Windows it is much more complicated due to the ASIO drivers.

My issue today was a bad USB cable. When I replaced it - all was well.

Getting the right Audio settings on the Mac and in JackTrip was essential. Once we had the correct settings, it was like butter.

1 Like

Thanks Beth. Long time! I hope you are well and still having fun playing music with JackTrip.

Yes, the session gave me more confidence for sure. Have a great evening.

At first I was definitely afraid of an ASIO issue with that mic since it doesn’t come with those drivers…

Surprised to hear of an issue like that on Mac! Was the mic just not showing up in the list? What was the eventual solution? Would love to make a USB mic like that “just work” so to speak

I had it working again today. The mic was showing up on the list, but when I tried to hit the Join button I got an error saying it could not find the mic.
Synthia had me select default mic in the app, and that appeared to solve the problem. Like I said, it worked just fine today. My student heard me and I heard him too.
Next, I will need to figure out a better solution for latency between SF and New York. Do you suggest using a server in the middle of the country, or one closer to my student in NY?

That’s interesting! Are you sure that the defaul mic was actually the Rode USB mic? Is it possible it was built-in instead?

I suspect some kind of sample rate mismatch or similar but admittedly not sure why that message would pop up after it was recognized in the list.

Yes, I am sure the default mic was the Rode USB. We set it up in the Audio midi on my Mac and I checked in System Preferences…will keep you apprised…

Beth - I thought you were my friend Beth Lyon - sorry for the confusion!

ASIO is a Windows-specific driver that provides low-latency functionality. The problem is that Windows doesn’t play nice with anything that is not Microsoft. ASIO was developed by Steinberg. Whereas Microsoft’s Direct Sound is commonly used as an intermediary signal path for non-professional users, ASIO allows access to external hardware directly, thus faster. Audio Stream Input/Output - Wikipedia

On the Mac, the Rode USB mic was in the list of devices, but it was not selected to be the default mic.

1 Like